iOS 15 Rumored to Drop Support for iPhone 6s and 2016 iPhone SE

Spread the love
  • Yum

Apple’s upcoming iOS 15 operating system, which we expect to see unveiled in June, is rumored to be dropping support for a few of Apple’s older iPhones.

iOS 15 icon mock banner


According to French site iPhoneSoft, ‌iOS 15‌ will not be able to be installed on the iPhone 6s, the ‌iPhone‌ 6s Plus, or the 2016 iPhone SE, all of which have an A9 chip.

The ‌iPhone‌ 6s and 6s Plus were introduced in 2015 and are now more than five years old, so it is not a surprise that the smartphones are not expected to be able to run ‌iOS 15‌. If the rumors are true, these iPhones will not be able to be updated past iOS 14.

‌iOS 15‌ will run on the ‌iPhone‌ 7, ‌iPhone‌ 7 Plus, and all newer iPhones that have been released, making it compatible with devices that have an A10 chip or newer. The seventh-generation iPod touch has an A10 chip, so it should be able to run ‌iOS 15‌.

As for the iPad, iPadOS 15 could perhaps drop support for the iPad mini 4 (2015), iPad Air 2 (2014), and ‌iPad‌ 5 (2017), equipped with A8, A8X, and A9 chips, respectively. All newer iPads are expected to support the update.

This is the second time that we’ve heard that ‌iOS 15‌ will not be available on the ‌iPhone‌ 6s and the ‌iPhone SE‌, as Israeli site The Verifier said the same thing back in November.

Leave a Reply

%d bloggers like this: